Discussion:
compile mahout for spark2.2 and scala2.11
(too old to reply)
Pere Urbón Bayes
2017-12-13 19:11:02 UTC
Permalink
Hi,
my name is Pere, for a requirement in a project I am working on right now
I do need to compile mahout with spark2.2 and scala2.11. Sorry If I ask
stupid questions, is first time I dive into mahout project.

For this task I am mostly following the work and comments that started with
this thread.

http://mail-archives.apache.org/mod_mbox/mahout-user/201712.mbox/%***@VI1PR08MB2638.eurprd08.prod.outlook.com%3E

and procedure as in https://github.com/apache/mahout/pull/335

however when I compile the and do the package command in maven, I found
that hthe viennacl package breaks.

This is the last part of the error:

[ERROR] Failed to execute goal
org.codehaus.mojo:exec-maven-plugin:1.1.1:exec (viennacl-2.11) on project
apache-mahout-distribution: Result of /bin/sh -c cd
/home/purbon/apache/mahout/viennacl && mvn package -Dscala.version=2.11.8
-Dscala.compat.version=2.11 -DskipTests execution is: '1'. -> [Help 1]


I have followed setup to install it as recommended from
http://mahout.apache.org/developers/buildingmahout.html

As I understood from the source of your previous comments on the thread,
looks like I should be able to compile the version, however I can not, can
you help me with that?

Does it makes sense to skip the viennacl package build?


Looking forward to get this understood! and help where I can.


- purbon
Trevor Grant
2017-12-13 21:23:42 UTC
Permalink
Hi Pere,

Do you need ViennaCL support? ViennaCL is basically prototype GPU support.

If not, change viennacl as described on that webpage:
cd buildtools/
./change-scala-version.sh 2.11

cd ..
mvn clean package -Pscala-2.11, -Dspark.version=2.2.0
-Dspark.compat.version=2.2 -DskipTests

Let me know if that helps or if you need more assistance.

tg
Post by Pere Urbón Bayes
Hi,
my name is Pere, for a requirement in a project I am working on right now
I do need to compile mahout with spark2.2 and scala2.11. Sorry If I ask
stupid questions, is first time I dive into mahout project.
For this task I am mostly following the work and comments that started with
this thread.
http://mail-archives.apache.org/mod_mbox/mahout-user/201712.mbox/%
eurprd08.prod.outlook.com%3E
and procedure as in https://github.com/apache/mahout/pull/335
however when I compile the and do the package command in maven, I found
that hthe viennacl package breaks.
[ERROR] Failed to execute goal
org.codehaus.mojo:exec-maven-plugin:1.1.1:exec (viennacl-2.11) on project
apache-mahout-distribution: Result of /bin/sh -c cd
/home/purbon/apache/mahout/viennacl && mvn package -Dscala.version=2.11.8
-Dscala.compat.version=2.11 -DskipTests execution is: '1'. -> [Help 1]
I have followed setup to install it as recommended from
http://mahout.apache.org/developers/buildingmahout.html
As I understood from the source of your previous comments on the thread,
looks like I should be able to compile the version, however I can not, can
you help me with that?
Does it makes sense to skip the viennacl package build?
Looking forward to get this understood! and help where I can.
- purbon
Continue reading on narkive:
Loading...